Fine Tuning 1 - 728x90


monthly amount

why donate?

+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 26 to 40 of 40

Thread: Harrison Ford, the ‘96 Ranger

  1. #26
                (⌐■_■)
    twardnw is just really nice twardnw is just really nice twardnw is just really nice twardnw is just really nice twardnw's Avatar
    Join Date
    Feb 2010
    Location
    The 'Couve
    Posts
    9,645
    Rep Power
    15
    that's awesome, I never knew that there was a cargo cover for the back seat in those!
    -Tyler-

  2. #27
    Quote: Originally Posted by twardnw View Post
    that's awesome, I never knew that there was a cargo cover for the back seat in those!
    Same here. I agree that's awesome!

  3. #28
    A Somebody Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody's Avatar
    Join Date
    May 2010
    Location
    Edmonds,WA
    Posts
    4,808
    Rep Power
    39
    Had a couple of OEM keys cut today, only had a generic one for it.


    Also ordered new shocks and a radio for it.

  4. #29
    Normal Member V8-190e is on a distinguished road V8-190e's Avatar
    Join Date
    Aug 2014
    Location
    Abbotsford BC
    Posts
    344
    Rep Power
    9
    This is fun to follow as I am kinda doing the same process to the s10 I bought... lots if pick a part yard searching for just better stock bits.

  5. #30
    A Somebody Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody's Avatar
    Join Date
    May 2010
    Location
    Edmonds,WA
    Posts
    4,808
    Rep Power
    39
    Last night I drained the coolant, refilled it with the coolant flush and drove it to work today. Going to use a flush kit tomorrow. The flush kit has a spout that goes into the radiator cap opening, it doesn’t fit very tight, so I got crafty. I took the drill and dremel to the old radiator cap and made it more secure.



  6. #31
    A Somebody Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody's Avatar
    Join Date
    May 2010
    Location
    Edmonds,WA
    Posts
    4,808
    Rep Power
    39
    Success! We have heat! Started the day by draining the coolant and pulling the all hoses. Used the hose with my nozzle to spray everything. Then I hooked everything up and used the flush kit. Got water flowing nice and clean. I pulled the hoses for the heater core and took the nozzle to the inlet port and noticed there was barely any flow coming from the outlet side. So I took the nozzle and for about 3 minutes shot into the inlet port. Then I shot through the outlet port and muddy, chunky nastiness came out the inlet port. Now it flows perfectly. Took a couple drives and had heat!

    When I put everything back together I used a coolant/washer fluid bottle that I grabbed from p-n-p that was cleaner to start with than the one in the truck. I cleaned it before putting it in. You will see in the pics how nasty the original was.

    Old





    New



    Did a couple of small things to. Hadn’t crossed my mind that the glovebox had a lock too, so when I went to p-n-p this morning I checked the truck I got the lock set from and it was still there so I grabbed it.



    Also changed a broken plug end to the main coil pack.

  7. #32
    Nice work! Almost looks like Bar's stop leak...horrible stuff.

  8. #33
    A Somebody Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody's Avatar
    Join Date
    May 2010
    Location
    Edmonds,WA
    Posts
    4,808
    Rep Power
    39
    That stop leak shit is horrible! I dug some out of the coolant bottle, it was just the everyday nastiness. The more I do to the truck the more I realize it was never really serviced in it’ 22 years.

  9. #34
    A Somebody Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody's Avatar
    Join Date
    May 2010
    Location
    Edmonds,WA
    Posts
    4,808
    Rep Power
    39
    Got a lot done this week after work, new fluid in the tranny, oil change, rebuilt shifter and installed a stereo.

    Remember to always solder and heat shrink your connections!



    Replaced the shocks, old ones were the originals and completely blown, drives great now!

    Front old vs new



    Rear old vs new


  10. #35
    A Somebody Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody's Avatar
    Join Date
    May 2010
    Location
    Edmonds,WA
    Posts
    4,808
    Rep Power
    39
    Changed the rear differential fluid yesterday, so all the fluids are up to date.

  11. #36
                (⌐■_■)
    twardnw is just really nice twardnw is just really nice twardnw is just really nice twardnw is just really nice twardnw's Avatar
    Join Date
    Feb 2010
    Location
    The 'Couve
    Posts
    9,645
    Rep Power
    15
    don't solder! quality crimp connection (non-insulated) and heat-shrink. Solder joints are susceptible to cracking from vibration over time
    -Tyler-

  12. #37
    Regular Member benny_mech will become famous soon enough
    Join Date
    Jan 2011
    Location
    Everwet
    Posts
    868
    Rep Power
    23
    I've heard that a lot, but I can't say I've ever seen a failed solder joint that wasn't done cold. I have seen failed crimps, but those are usually caused by crappy crimp tools.
    “Right now, it's like this.”
    ― Ajahn Sumedho

  13. #38
    A Somebody Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody's Avatar
    Join Date
    May 2010
    Location
    Edmonds,WA
    Posts
    4,808
    Rep Power
    39
    Installed the tow hitch, I think the wiring adapter is faulty. It was pretty corroded and one of the prongs is loose. Everything is working, but the brake lights. So I ordered a new one.



    I also installed a new tonneau cover. The one that came with it had a tear in the middle and had to be completely removed to use the bed. So I got a roll up one, should be way more useful.


  14. #39
    everyone probably knows me by now buddylove is a jewel in the rough buddylove is a jewel in the rough
    Join Date
    Feb 2010
    Posts
    1,923
    Rep Power
    31
    Looking good!

  15. #40
    A Somebody Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody is a jewel in the rough Mr.Nobody's Avatar
    Join Date
    May 2010
    Location
    Edmonds,WA
    Posts
    4,808
    Rep Power
    39
    Quote: Originally Posted by buddylove View Post
    Looking good!
    Thanks!

    So I have had a random misfire on the secondary coil for awhile, so I decided to upgrade both. So I did some research, as I am not fluent in Ford upgrades. Looked at the brands I knew about MSD and Accel, was leaning towards MSD ones. Did one more random Ford performance coil google search and across Napol Coils out of Canada. Found a lot of good reviews, they cost the same as one Accel or MSD coil for both of them. They arrived today and I am very pleased. Took it for a quick drive and noticed an instant improvement in acceleration. Can’t wait to drive it more and get more data.


+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts